博客
关于我
强烈建议你试试无所不能的chatGPT,快点击我
POJ3468 A simple problem with integers(区间更新)
阅读量:4598 次
发布时间:2019-06-09

本文共 2327 字,大约阅读时间需要 7 分钟。

A Simple Problem with Integers
Time Limit: 5000MS Memory Limit: 131072K
Total Submissions: 55949 Accepted: 16877
Case Time Limit: 2000MS

Description

You have N integers, A1A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.

The second line contains N numbers, the initial values of A1A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C a b c" means adding c to each of AaAa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q a b" means querying the sum of AaAa+1, ... , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 51 2 3 4 5 6 7 8 9 10Q 4 4Q 1 10Q 2 4C 3 6 3Q 2 4

Sample Output

455915
wa了好多次,最后终于ac了
#include<stdio.h>
#include<algorithm>
using namespace std;
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
const int maxn=111111;
__int64 sum[maxn<<2];                      //不定义__int64为必wa
__int64 vis[maxn<<2];
void pushup(int rt)
{
sum[rt]=sum[rt<<1]+sum[rt<<1|1];
}
void pushdown(int rt,int m)
{
if(vis[rt])
{
vis[rt<<1]+=vis[rt];
vis[rt<<1|1]+=vis[rt];
sum[rt<<1]+=(m-(m>>1))*vis[rt];
sum[rt<<1|1]+=(m>>1)*vis[rt];
vis[rt]=0;                           //这里最后记得置为零
}
}
void build(int l,int r,int rt)
{
vis[rt]=0;
if(l==r)
{
scanf("%I64d",&sum[rt]);            //输入也要__int64
return;
}
     int m=(l+r)>>1;
build(lson);
build(rson);
pushup(rt);
}
void update(int L,int R,int add,int l,int r,int rt)
{
    if(L <=l&&R>=r)
    {
vis[rt]+=add;
sum[rt]+=add*(r-l+1);
return;
}
pushdown(rt,r-l+1);
int m=(l+r)>>1;
if(L <=m)
update(L,R,add,lson);
if(R>m)
update(L,R,add,rson);
pushup(rt);
}
__int64 getsum(int L,int R,int l,int r,int rt)
{
__int64 ret=0;                       //因为这里没有定义__int64错了好几次
if(L <=l&&R >=r)
{
return sum[rt];
}
pushdown(rt,r-l+1);                     //求和也要pushdown??反正我不明白为什么,以后再看
int m=(l+r)>>1;
if(L <=m)
ret+=getsum(L,R,lson); 
if(R >m)
ret+=getsum(L,R,rson);
   return ret;
}
int main()
{
int a,b,x,y,z,n,m;
char s[5];
scanf("%d%d",&n,&m);
build(1,n,1);
for(int i=0;i<m;i++)
   {
scanf("%s",s);
if(s[0]=='Q')
{
scanf("%d%d",&a,&b);
printf("%I64d\n",getsum(a,b,1,n,1));
}
if(s[0]=='C')
{
scanf("%d%d%d",&x,&y,&z);
update(x,y,z,1,n,1);
}
}
return 0;
}

转载于:https://www.cnblogs.com/tanjianwen/p/5245433.html

你可能感兴趣的文章
BZOJ1609 [Usaco2008 Feb]Eating Together麻烦的聚餐
查看>>
ffmpeg静态库Windows版本
查看>>
LeetCode Weekly Contest 18B
查看>>
CTS类型系统
查看>>
Cisco 交换机配置的基本命令
查看>>
MVC Filter自定义验证(拦截)
查看>>
高可用数据采集平台(如何玩转3门语言php+.net+aauto)
查看>>
201521123017 《Java程序设计》第2周学习总结
查看>>
Linux curl命令详解
查看>>
charles
查看>>
如何查看包名
查看>>
ffmpeg常用参数一览表
查看>>
Java实现文件拷贝的4种方法.
查看>>
一元四次方程求根公式
查看>>
private,protected,public和internal的区别
查看>>
LA3029 City Game
查看>>
第一次作业
查看>>
Kinect控制PowerPoint播放
查看>>
Unix Notes.
查看>>
Java基础复习3
查看>>